Gtfo - Search For Unix Binaries That Can Be Exploited To Bypass System Security Restrictions

gtfo_3.png

This is a standalone script written in Python 3 for GTFOBins. You can search for Unix binaries that can be exploited to bypass system security restrictions. These binaries can be abused to

get the f**k

break out of restricted shells, escalate privileges, transfer files, spawn bind and reverse shells, etc...

Download
git clone https://github.com/t0thkr1s/gtfo

Install
The script has 2 dependencies:
You can install these by typing:
python3 setup.py install

Run
python3 gtfo.py [binary]

Screenshots


gtfo_3.png

gtfo_4.png

Disclaimer
This tool is only for testing and academic purposes and can only be used where strict consent has been given. Do not use it for illegal purposes! It is the end user’s responsibility to obey all applicable local, state and federal laws. Developers assume no liability and are not responsible for any misuse or damage caused by this tool and software.

Дата: 2020-01-14 20:30:02

Источник: http://www.kitploit.com/2020/01/gtfo-search-for-unix-binaries-that-can.html